<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="user-scalable=no width=device-width, initial-scale=1">
<script src="/cdn-cgi/apps/head/f-4CGQCrMUnIW19Y6lKMzArTWjQ.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css" />

<link rel="manifest" href="/superpwa-manifest.json">
<meta name="theme-color" content="#07294d">
<link rel="apple-touch-icon" sizes="192x192" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-192x192.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-512x512.png">

<title>West Philadelphia&#039;s best features lie just beyond campus - The Triangle</title>

<link rel="canonical" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="West Philadelphia&#039;s best features lie just beyond campus - The Triangle" />
<meta property="og:description" content="Drexel University’s and University of Pennsylvania’s campuses combine to create “University City,” which takes the form of an urban college town. They have the feel&hellip;" />
<meta property="og:url" content="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/" />
<meta property="og:site_name" content="The Triangle" />
<meta property="article:publisher" content="https://www.facebook.com/drexel.triangle/" />
<meta property="article:tag" content="Belmont" />
<meta property="article:tag" content="Belmont Plateau" />
<meta property="article:tag" content="Cobbs Creek" />
<meta property="article:tag" content="Drexel" />
<meta property="article:tag" content="Drexel University" />
<meta property="article:tag" content="Fairmount Park" />
<meta property="article:tag" content="lancaster avenue" />
<meta property="article:tag" content="mantua" />
<meta property="article:tag" content="neighborhood" />
<meta property="article:tag" content="Philadelphia" />
<meta property="article:tag" content="Philadelphia Zoo" />
<meta property="article:tag" content="Please Touch Museum" />
<meta property="article:tag" content="powelton village" />
<meta property="article:tag" content="Spruce Hill" />
<meta property="article:tag" content="University City" />
<meta property="article:tag" content="walnut hill" />
<meta property="article:tag" content="West Parkside" />
<meta property="article:tag" content="West Philadelphia" />
<meta property="article:tag" content="West Philly" />
<meta property="article:tag" content="west powelton" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-09-14T12:03:12-04:00" />
<meta property="article:modified_time" content="2019-09-14T05:33:13-04:00" />
<meta property="og:updated_time" content="2019-09-14T05:33:13-04:00" />
<meta property="og:image" content="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png" />
<meta property="og:image:secure_url" content="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="1045" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Drexel University’s and University of Pennsylvania’s campuses combine to create “University City,” which takes the form of an urban college town. They have the feel&hellip;" />
<meta name="twitter:title" content="West Philadelphia&#039;s best features lie just beyond campus - The Triangle" />
<meta name="twitter:site" content="@thetriangle" />
<meta name="twitter:image" content="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png" />
<meta name="twitter:creator" content="@thetriangle" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.thetriangle.org/#website","url":"https://www.thetriangle.org/","name":"The Triangle","potentialAction":{"@type":"SearchAction","target":"https://www.thetriangle.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/#primaryimage","url":"https://www.thetriangle.org/wp-content/uploads/2019/09/west.png","width":720,"height":1045},{"@type":"WebPage","@id":"https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/#webpage","url":"https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/","inLanguage":"en-US","name":"West Philadelphia&#039;s best features lie just beyond campus - The Triangle","isPartOf":{"@id":"https://www.thetriangle.org/#website"},"primaryImageOfPage":{"@id":"https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/#primaryimage"},"datePublished":"2019-09-14T12:03:12-04:00","dateModified":"2019-09-14T05:33:13-04:00","author":{"@id":"https://www.thetriangle.org/#/schema/person/1574b639a3803f4ee6f47de1e480dd81"}},{"@type":["Person"],"@id":"https://www.thetriangle.org/#/schema/person/1574b639a3803f4ee6f47de1e480dd81","name":"Jason Sobieski","image":{"@type":"ImageObject","@id":"https://www.thetriangle.org/#authorlogo","url":"https://secure.gravatar.com/avatar/f237bd2201b3b0d1d7ef643c22581eb8?s=96&d=mm&r=g","caption":"Jason Sobieski"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Feed" href="https://www.thetriangle.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Comments Feed" href="https://www.thetriangle.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; West Philadelphia&#8217;s best features lie just beyond campus Comments Feed" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thetriangle.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.thetriangle.org/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='flytedesk-digital-css' href='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.thetriangle.org/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='triangle-x-style-css' href='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='authorizer-public-css-css' href='https://www.thetriangle.org/wp-content/plugins/authorizer/css/authorizer-public.css?ver=2.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/css/jetpack.css?ver=7.7.1' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8310cb-bac8-481b-88b4-5c347d3aea8f"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var auth = {"wpLoginUrl":"https:\/\/www.thetriangle.org\/square?redirect_to=%2Fnews%2Fwest-philadelphias-best-features-lie-just-beyond-campus%2F","publicWarning":"","anonymousNotice":"Notice: You are browsing this site anonymously, and only have access to a portion of its content.","logIn":"Log In"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/authorizer/js/authorizer-public.js?ver=2.8.0'></script>
<link rel='https://api.w.org/' href='https://www.thetriangle.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thetriangle.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thetriangle.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.2.3" />
<link rel='shortlink' href='https://wp.me/p1tmKW-cW4' />
<link rel="alternate" type="application/json+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fnews%2Fwest-philadelphias-best-features-lie-just-beyond-campus%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fnews%2Fwest-philadelphias-best-features-lie-just-beyond-campus%2F&#038;format=xml" />

<link rel="icon" type="image/x-icon" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle.ico">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76.png">
<link rel="apple-touch-icon-precomposed" sizes="180x180" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60.png">
<link rel="apple-touch-icon-precomposed" sizes="80x80" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="40x40" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40.png">
<link rel="apple-touch-icon-precomposed" sizes="87x87" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="58x58" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="29x29" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small.png">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-162588-4"></script>
<script>
	window.dataLayer = window.dataLayer || [];
	function gtag(){dataLayer.push(arguments);}
	gtag('js', new Date());

	gtag('config', 'UA-162588-4');
	</script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style> <meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://www.thetriangle.org/superpwa-manifest.json" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.thetriangle.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '38dcdf59-7ae4-4794-90ed-5b29d7d04635';
oneSignal_options['autoRegister'] = false;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "The Triangle";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.thetriangle.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.55479a10-4eda-4299-901a-290da3fd1836";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
</head>
<body>
<header id="header-global" class="header-global" role="banner">
<div id="header-search-icon" class="header-search-icon white">
<i class="material-icons md-36">search</i>
</div>
<div class="search-container">
<form role="search" method="get" class="search-form" action="https://www.thetriangle.org">
<input id="searchbox-main" type="search" class="search-textbox" placeholder="Search..." value="" name="s">
</form>
</div>
<div class="header-logo">
<div class="header-logo-desktop">
<a id="triangle-logo" href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-white.svg"></img>
</a>
</div>
<a id="menu-notif" style="color: white; font-size: 12px; right: 60px; position: absolute;">Menu</a>
</div>
<div class="header-logo-mobile">
<div class="img-container">
<a href="https://www.thetriangle.org/" rel="home"><img id="logo-mobile" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/tri-icon.png"></img></a>
</div>
</div>
<div id="nav-icon" class="header-hamburger-icon white"><span></span><span></span><span></span></div>
</header>
<div id="nav-main" class="header-nav-container">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="main"><li id="menu-item-40351" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40351"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-40353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40353"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-40350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40350"><a href="https://www.thetriangle.org/entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-40352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40352"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
</ul></div><div class="menu-sub-menu-container"><ul id="menu-sub-menu" class="sub"><li id="menu-item-46974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46974"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-40358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40358"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-46705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46705"><a href="https://www.thetriangle.org/join/">Join The Triangle</a></li>
<li id="menu-item-40354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40354"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-40356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40356"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-40355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40355"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-40357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40357"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></div></div>
<div class="generic-wrapper">
<title>West Philadelphia&#8217;s best features lie just beyond campus | The Triangle</title>
<div class="ad-container-banner-top"><div class="flytead leaderboard 8d3354da-c6b7-46ed-9d8f-77c4b0c53e7c"></div></div>
<div class="generic-container" style="margin-bottom: 0px;">
<div class="print-logo"><img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/images/logo-black.svg"></img></div>
<div class="single-title">
<h1>West Philadelphia&#8217;s best features lie just beyond campus</h1> </div>
<div class="single-meta">
<div class="author">By <a href="https://www.thetriangle.org/author/ethan-hermann/" title="Posts by Ethan Hermann" class="author url fn" rel="author">Ethan Hermann</a></div>
<div class="date">Sep. 14, 2019</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-49728" class="share-facebook sd-button share-icon no-text" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-49728" class="share-twitter sd-button share-icon no-text" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-49728" class="share-linkedin sd-button share-icon no-text" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.thetriangle.org/news/west-philadelphias-best-features-lie-just-beyond-campus/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
</div>
<div id="post-49728" class="generic-flex-container">
<main id="content" class="flex-main">
<article class="single-content">
<figure id="attachment_49800" aria-describedby="caption-attachment-49800" style="width: 720px" class="wp-caption alignnone"><img class="wp-image-49800 size-full jetpack-lazy-image" src="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png" alt width="720" height="1045" data-lazy-srcset="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png 720w, https://www.thetriangle.org/wp-content/uploads/2019/09/west-207x300.png 207w, https://www.thetriangle.org/wp-content/uploads/2019/09/west-706x1024.png 706w" data-lazy-sizes="(max-width: 720px) 100vw, 720px" data-lazy-src="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-49800 size-full" src="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png" alt="" width="720" height="1045" srcset="https://www.thetriangle.org/wp-content/uploads/2019/09/west.png 720w, https://www.thetriangle.org/wp-content/uploads/2019/09/west-207x300.png 207w, https://www.thetriangle.org/wp-content/uploads/2019/09/west-706x1024.png 706w" sizes="(max-width: 720px) 100vw, 720px" /></noscript><figcaption id="caption-attachment-49800" class="wp-caption-text">The houses of Mantua and Powelton Village, just north of campus, are some of the most charming in all of Philadelphia. The residence halls were built on a demolished part of this neighborhood. (Photograph by Ben Ahrens for The Triangle.)</figcaption></figure>
<p>Drexel University’s and University of Pennsylvania’s campuses combine to create “University City,” which takes the form of an urban college town. They have the feel of college campuses but are nestled in West Philadelphia.</p>
<p>Center City and Rittenhouse Square are a quick walk or SEPTA ride away to the east. South Philly can be reached with a SEPTA ride and free transfer at City Hall, or by a longer walk through Penn’s campus and across the South Street Bridge. Areas like Fishtown and Penn’s Landing can be reached by taking a single SEPTA ride all the way across the city.</p>
<p>All of these neighborhoods and places in Philly are big destinations with a lot of restaurants, cafes, shops and attractions, but what about what is right next door to Drexel?</p>
<p>West Philadelphia isn’t meant to be a tourist destination. It’s not meant to be a place where everyone will flock to. It’s meant to be a place where you feel at home, and where the people around you become your community.</p>
<p>While “University City” is  in West Philadelphia, it isn’t a part of West Philly. It is its own thing, and around the bubble of the two college campuses lies a vibrant, diverse and community.</p>
<p>In a 2015 PhillyVoice article, writer Michael Fichman tries to explain his own neighborhood and why he believes it is the best  in Philadelphia. However, West Philadelphia isn’t just one neighborhood.</p>
<p>“This task is complicated by the fact that I’m not sure exactly how to delineate my part of the neighborhood. West and Southwest Philly are made up of dozens of micro-hoods and about 300,000 people,&#8221; Fichman said.</p>
<p>West Philadelphia has places where you feel connected to the place you live, not just to the city your house is a part of.</p>
<p>Northwest of Drexel’s campus, you’ll find the neighborhoods of Powelton Village, Mantua, Belmont and West Parkside. There are attractions like the Philadelphia Zoo, Fairmount Park and all of the trails that create the famous Belmont Plateau.</p>
<p>In Fairmount, there is the Please Touch Museum, the Fairmount Park Horticulture Center, the Shofuso Japanese House and Garden and the Centennial Arboretum along the beautiful tree-lined paths.</p>
<p>Looking west past Penn’s campus, there are the neighborhoods of Spruce Hill, Walnut Hill, Cobbs Creek and West Powelton. If you go west along Market Street to 40th, you will find rows of family-owned restaurants and shops that give back to the local community. If you take Lancaster Avenue west past 37th, you’ll find the exact same scene, with people sitting outside the shops and restaurants, old friends and neighbors catching up on the sidewalk.</p>
<p>If you go southwest of Penn’s campus, tucked away are some beautiful and downright hidden gems of Philadelphia. There is first The Woodlands: a cemetery with a walking path centered around a stunning mansion. Follow along Baltimore Avenue to the charming Clark Park, which shows outdoor movies in the summertime and hosts events such as Parks on Tap, local farmers markets and arts and music festivals.</p>
<p>The Spruce Hill area is also home to a large Ethiopian population, which is highlighted by the number of restaurants and markets in the area. As you go further south, you run into the University of the Sciences and some local bakeries — Four Worlds Bakery is supposed to be well worth the visit — in Squirrel Hill and Cedar Park.</p>
<p>Finally, there is Kingessing. A neighborhood home to schools, churches and the beautiful Bartram’s Garden. It bridges the gap between West and Southwest Philadelphia while also leading into Gray’s Ferry, a South Philly neighborhood on the Schuylkill River.</p>
<p>These are all as close to Drexel’s campus — if not closer — than Center City and the rest of Philadelphia east of the Schuylkill, but there is something to be said about the unique destinations in West Philadelphia:</p>
<p>You could start exploring now and still never see all that it has to offer.</p>
</article>
<div id="comments" class="single-comments">
<div id="disqus_thread"></div>
</div>
</main>
<aside id="sidebar" class="flex-sidebar">
<div class="ad-container-medium-rectangle"><div class="flytead rectangle 8b8310cb-e928-4379-95c5-5edd76144fcf"></div></div> <div id="tx_mailchimp_newsletter-3" class="sidebar-item widget_tx_mailchimp_newsletter"><div class="sidebar-title">Sign up for our newsletter</div><p>Get The Triangle's top stories directly to your inbox every Friday</p> <div id="mc_embed_signup">
<form action="//thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&amp;id=7389750c95" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="mc-field-group">
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="email@example.com">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_6eb4aab81745d3436b16a6181_7389750c95" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div><div id="polls-widget-3" class="sidebar-item widget_polls-widget"><div class="sidebar-title">Weekly Poll</div><div id="polls-168" class="wp-polls">
<form id="polls_form_168" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_168_nonce" name="wp-polls-nonce" value="e0a5a411f4" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="168" /></p>
<h1>Do you think more could be done at Drexel to address discrimination?</h1>
<div id="polls-168-ans" class="wp-polls-ans">
<ul class="wp-polls-ul">
<li>
<input type="radio" id="poll-answer-499" name="poll_168" value="499" />
<label for="poll-answer-499">Yes</label>
</li>
<li>
<input type="radio" id="poll-answer-500" name="poll_168" value="500" />
<label for="poll-answer-500">No</label>
</li>
<li>
<input type="radio" id="poll-answer-501" name="poll_168" value="501" />
<label for="poll-answer-501">Not sure</label>
</li>
</ul>
<div class="footer">
<input type="button" name="vote" value="Vote" class="tri-button" onclick="poll_vote(168);" />
<a href="#ViewPollResults" class="tri-button" onclick="poll_result(168); return false;" title="View Results Of This Poll">View Results</a>
</div>
</div>
</form>
</div>
<a href="http://thetriangle.org/pollsarchive" class="tri-button">Polls Archive</a></div><div id="tx_social_widget-3" class="sidebar-item widget_tx_social_widget"><div class="sidebar-title">Follow us</div><ul class="social-links">
<li class="social-item">
<i class="fa fa-facebook" style="color: #3b5998;"></i>
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">Drexel Triangle</a>
</li>
<li class="social-item">
<i class="fa fa-twitter" style="color: #00acee;"></i>
<a href="https://twitter.com/drexeltriangle" target="_blank">@DrexelTriangle</a>
</li>
<li class="social-item">
<i class="fa fa-instagram text-instagram"></i>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">@drexeltriangle</a>
</li>
<li class="social-item">
<i class="fa fa-youtube-play" style="color: #e52d27;"></i>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">DrexelTriangle</a>
</li>
</ul></div> <div class="ad-container-medium-rectangle">

<div id="538119722_INSERT_SLOT_ID_HERE" style="width:300px;height:250px;margin:0;padding:0">
<noscript><iframe id="a79c035e7a" name="a79c035e7a" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119722&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119722&cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119722_INSERT_SLOT_ID_HERE",
     auid: "538119722"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div> </aside>
</div>
<div class="ad-container-banner-bottom">

<div id="538317146_INSERT_SLOT_ID_HERE" style="width:728px;height:90px;margin:0;padding:0">
<noscript><iframe id="9e6e8ebf9f" name="9e6e8ebf9f" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538317146&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538317146&cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538317146_INSERT_SLOT_ID_HERE",
     auid: "538317146"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div></div>
<footer id="colophon" class="footer-wrapper">
<div class="footer-container">
<div class="footer-branding">
<div class="footer-logo">
<a href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-black.svg"></img>
</a>
</div>
<div class="footer-social">
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #3b5998;"></i>
<i class="fa fa-facebook fa-stack-1x"></i>
</span>
</a>
<a href="https://twitter.com/drexeltriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #00acee;"></i>
<i class="fa fa-twitter fa-stack-1x"></i>
</span>
</a>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x text-instagram"></i>
<i class="fa fa-instagram fa-stack-1x"></i>
</span>
</a>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #e52d27;"></i>
<i class="fa fa-youtube-play fa-stack-1x"></i>
</span>
</a>
<a href="https://thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&id=7389750c95" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #07294D;"></i>
<i class="fa fa-envelope-o fa-stack-1x"></i>
</span>
</a>
</div>
<div class="footer-tagline">
THE INDEPENDENT STUDENT NEWSPAPER AT DREXEL UNIVERSITY SINCE 1926
</div>
</div>
<nav class="footer-nav-container"><ul id="menu-footer-menu" class="footer-nav-links"><li id="menu-item-43823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-43823"><a href="https://www.thetriangle.org">Home</a></li>
<li id="menu-item-43824" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43824"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-43826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43826"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-43827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43827"><a href="https://www.thetriangle.org/entertainment/">A&#038;E</a></li>
<li id="menu-item-43825" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43825"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-46975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46975"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-43828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43828"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-43831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43831"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-43829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43829"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-43830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43830"><a href="https://www.thetriangle.org/join/">Join</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></nav> </div>
<div class="footer-copyright">
&copy2019 The Triangle. All rights are reserved, except where otherwise noted.
</div>
<div class="footer-disclaimer">
The Triangle is an independent student organization and is not owned nor operated by Drexel University.
</div>
</footer>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.thetriangle.org\/news\/west-philadelphias-best-features-lie-just-beyond-campus\/":49728};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.thetriangle.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"triangle"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"49728 https:\/\/www.thetriangle.org\/?p=49728","disqusShortname":"triangle","disqusTitle":"West Philadelphia\u2019s best features lie just beyond campus","disqusUrl":"https:\/\/www.thetriangle.org\/news\/west-philadelphias-best-features-lie-just-beyond-campus\/","postId":"49728"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201937'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.thetriangle.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"0","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/jquery.viewport.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/search.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.7.1'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201937.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.7.1',blog:'21775326',post:'49728',tz:'-4',srv:'www.thetriangle.org'} ]);
	_stq.push([ 'clickTrackerInit', '21775326', '49728' ]);
</script>
</body>
</html>
