<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="user-scalable=no width=device-width, initial-scale=1">
<script src="/cdn-cgi/apps/head/f-4CGQCrMUnIW19Y6lKMzArTWjQ.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css" />

<link rel="manifest" href="/superpwa-manifest.json">
<meta name="theme-color" content="#07294d">
<link rel="apple-touch-icon" sizes="192x192" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-192x192.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-512x512.png">

<title>A look at the negative buzz around Captain Marvel ahead of its release this Friday - The Triangle</title>

<link rel="canonical" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A look at the negative buzz around Captain Marvel ahead of its release this Friday - The Triangle" />
<meta property="og:description" content="Following the announcement of the production of Marvel’s newest cinematic installment, Captain Marvel, it is unfortunate to say that there was as much hatred for&hellip;" />
<meta property="og:url" content="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/" />
<meta property="og:site_name" content="The Triangle" />
<meta property="article:publisher" content="https://www.facebook.com/drexel.triangle/" />
<meta property="article:tag" content="brie larsson" />
<meta property="article:tag" content="captain marvel" />
<meta property="article:tag" content="carol danvers" />
<meta property="article:tag" content="marvel" />
<meta property="article:tag" content="superhero" />
<meta property="article:section" content="Arts &amp; Entertainment" />
<meta property="article:published_time" content="2019-03-06T21:49:57-05:00" />
<meta property="og:image" content="http://files.thetriangle.org/assets/default/triangle-default.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Following the announcement of the production of Marvel’s newest cinematic installment, Captain Marvel, it is unfortunate to say that there was as much hatred for&hellip;" />
<meta name="twitter:title" content="A look at the negative buzz around Captain Marvel ahead of its release this Friday - The Triangle" />
<meta name="twitter:site" content="@thetriangle" />
<meta name="twitter:image" content="http://files.thetriangle.org/assets/default/triangle-default.png" />
<meta name="twitter:creator" content="@thetriangle" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://www.thetriangle.org/","sameAs":["https://www.facebook.com/drexel.triangle/","https://www.instagram.com/drexeltriangle/","https://www.youtube.com/user/DrexelTriangle","https://twitter.com/thetriangle"],"@id":"https://www.thetriangle.org/#organization","name":"The Triangle","logo":"http://thetriangle.org/wp-content/uploads/2016/06/triangle-1.png"}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Feed" href="https://www.thetriangle.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Comments Feed" href="https://www.thetriangle.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; A look at the negative buzz around Captain Marvel ahead of its release this Friday Comments Feed" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thetriangle.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.thetriangle.org/wp-includes/css/dist/block-library/style.min.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='flytedesk-digital-css' href='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.thetriangle.org/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='triangle-x-style-css' href='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1/style.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='authorizer-public-css-css' href='https://www.thetriangle.org/wp-content/plugins/authorizer/css/authorizer-public.css?ver=2.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8310cb-bac8-481b-88b4-5c347d3aea8f"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var auth = {"wpLoginUrl":"https:\/\/www.thetriangle.org\/square?redirect_to=%2Fentertainment%2Fa-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday%2F","publicWarning":"","anonymousNotice":"Notice: You are browsing this site anonymously, and only have access to a portion of its content.","logIn":"Log In"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/authorizer/js/authorizer-public.js?ver=2.8.0'></script>
<link rel='https://api.w.org/' href='https://www.thetriangle.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thetriangle.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thetriangle.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.1" />
<link rel='shortlink' href='https://wp.me/p1tmKW-ctc' />
<link rel="alternate" type="application/json+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fentertainment%2Fa-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fentertainment%2Fa-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday%2F&#038;format=xml" />

<link rel="icon" type="image/x-icon" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle.ico">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76.png">
<link rel="apple-touch-icon-precomposed" sizes="180x180" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60.png">
<link rel="apple-touch-icon-precomposed" sizes="80x80" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="40x40" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40.png">
<link rel="apple-touch-icon-precomposed" sizes="87x87" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="58x58" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="29x29" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small.png">
<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', 'UA-162588-7', 'auto');
	  ga('send', 'pageview');
	</script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style> <meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://www.thetriangle.org/superpwa-manifest.json" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.thetriangle.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '38dcdf59-7ae4-4794-90ed-5b29d7d04635';
oneSignal_options['autoRegister'] = false;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "The Triangle";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.thetriangle.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.55479a10-4eda-4299-901a-290da3fd1836";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
</head>
<body>
<header id="header-global" class="header-global" role="banner">
<div id="header-search-icon" class="header-search-icon white">
<i class="material-icons md-36">search</i>
</div>
<div class="search-container">
<form role="search" method="get" class="search-form" action="https://www.thetriangle.org">
<input id="searchbox-main" type="search" class="search-textbox" placeholder="Search..." value="" name="s">
</form>
</div>
<div class="header-logo">
<div class="header-logo-desktop">
<a id="triangle-logo" href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1//images/logo-white.svg"></img>
</a>
</div>
<a id="menu-notif" style="color: white; font-size: 12px; right: 60px; position: absolute;">Menu</a>
</div>
<div class="header-logo-mobile">
<div class="img-container">
<a href="https://www.thetriangle.org/" rel="home"><img id="logo-mobile" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1//images/tri-icon.png"></img></a>
</div>
</div>
<div id="nav-icon" class="header-hamburger-icon white"><span></span><span></span><span></span></div>
</header>
<div id="nav-main" class="header-nav-container">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="main"><li id="menu-item-40351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40351"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-40353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40353"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-40350" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40350"><a href="https://www.thetriangle.org/entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-40352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40352"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
</ul></div><div class="menu-sub-menu-container"><ul id="menu-sub-menu" class="sub"><li id="menu-item-46974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46974"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-40358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40358"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-46705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46705"><a href="https://www.thetriangle.org/join/">Join The Triangle</a></li>
<li id="menu-item-40354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40354"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-40356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40356"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-40355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40355"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-40357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40357"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></div></div>
<div class="generic-wrapper">
<title>A look at the negative buzz around Captain Marvel ahead of its release this Friday | The Triangle</title>
<div class="ad-container-banner-top">
<div id="538119720_INSERT_SLOT_ID_HERE" style="width:728px;height:90px;margin:0;padding:0">
<noscript><iframe id="bf0ba1060c" name="bf0ba1060c" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119720&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=bf0ba1060c&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119720&cs=bf0ba1060c&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119720_INSERT_SLOT_ID_HERE",
     auid: "538119720"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script></div>
<div class="generic-container" style="margin-bottom: 0px;">
<div class="print-logo"><img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1/images/logo-black.svg"></img></div>
<div class="single-title">
<h1>A look at the negative buzz around Captain Marvel ahead of its release this Friday</h1> </div>
<div class="single-meta">
<div class="author">By <a href="https://www.thetriangle.org/author/pooja-balar/" title="Posts by Pooja Balar" class="author url fn" rel="author">Pooja Balar</a></div>
<div class="date">Mar. 6, 2019</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-47938" class="share-facebook sd-button share-icon no-text" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-47938" class="share-twitter sd-button share-icon no-text" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-47938" class="share-linkedin sd-button share-icon no-text" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.thetriangle.org/entertainment/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
</div>
<div id="post-47938" class="generic-flex-container">
<main id="content" class="flex-main">
<article class="single-content">
<p>Following the announcement of the production of Marvel’s newest cinematic installment, Captain Marvel, it is unfortunate to say that there was as much hatred for the new star-spangled hero as there was awe and admiration.</p>
<p>As always, arbitrary trolling and unjustifiable dissatisfaction beg the question: Why?</p>
<p>After having discovered arguably one of my favorite comic book characters in the summer of 2015, my dreams finally came true in 2016 when President of Marvel Studios Kevin Feige announced the film adaptation of Captain Marvel at San Diego Comic-Con. However, it came as a crushing defeat when the reality of the situation was that seemingly half of humanity already hated the idea of a woman taking the lead of this beloved franchise.</p>
<p style="text-align: center"><div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='640' height='360' src='https://www.youtube.com/embed/0LHxvxdRnYc?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></div></p>
<p>I have spent enough time browsing through social media to identify the three main categories of hatred that Carol Danvers has been receiving: the white male inferiority complex, the “you should smile more” saga and just downright disinterest.</p>
<p>The first category is actually as hilarious as it is irritating. The slew of comments on Marvel’s instagram trailers for the movie such as, “I’m a white male. Guess I can’t see this movie.” are ridiculous. To put it simply: We are females and we loved Iron Man, Batman, The Hulk, Men In Black, etc. Unless the Motion Picture Association of America has suddenly introduced the WO rating, “Women Only,” there is no need for vacuous assumptions like these.</p>
<p>The second category is one that women are incredibly fed up with, and even more frustrated that it is now being translated onto the big screen. Marvel is a franchise that could literally patent a trademark for its iconic humor; to think for a second that some people believed it was going to exempt this movie from that pattern blows my mind. Carol Danvers is a rather serious character with a witty and somewhat dark sense of humor. Going into this movie, I neither expected things like Mantis-type behavior nor like Natasha Romanoff’s no-nonsense attitude, but rather a mix of them.</p>
<p>The third and final category is contingent upon collective behaviorism. The way I see it, the people commenting “Where’s the Avengers 4 Trailer? I don’t care about this movie!” are really just trying to discourage people from wanting to see Captain Marvel in hopes that their efforts will keep the film from succeeding at the box office for some odd reason. Hate to rain on their parade, but our Captain is projected to crush a $150 billion domestic opening, according to Forbes. Try as you will, but I guarantee your efforts are in vain.</p>
<p>Needless to say, this glowing, red, blue and gold-clad hero radiates power and promise, and she is unlike anyone you have ever seen before. She is going higher, further and faster than any other hero, and more importantly, she is finally here. The wait is over; space has a new boss, and the skies of Earth-64 have a new protector. Her name is Captain Marvel.</p>
</article>
<div id="comments" class="single-comments">
<div id="disqus_thread"></div>
</div>
</main>
<aside id="sidebar" class="flex-sidebar">
<div class="ad-container-medium-rectangle">
<div id="538119721_INSERT_SLOT_ID_HERE" style="width:300px;height:250px;margin:0;padding:0">
<noscript><iframe id="02d25960dc" name="02d25960dc" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119721&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=02d25960dc&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119721&cs=02d25960dc&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119721_INSERT_SLOT_ID_HERE",
     auid: "538119721"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div> <div id="tx_mailchimp_newsletter-3" class="sidebar-item widget_tx_mailchimp_newsletter"><div class="sidebar-title">Sign up for our newsletter</div><p>Get The Triangle's top stories directly to your inbox every Friday</p> <div id="mc_embed_signup">
<form action="//thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&amp;id=7389750c95" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="mc-field-group">
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="email@example.com">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_6eb4aab81745d3436b16a6181_7389750c95" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div><div id="polls-widget-3" class="sidebar-item widget_polls-widget"><div class="sidebar-title">Weekly Poll</div><div id="polls-168" class="wp-polls">
<form id="polls_form_168" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_168_nonce" name="wp-polls-nonce" value="6d4d58d29f" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="168" /></p>
<h1>Do you think more could be done at Drexel to address discrimination?</h1>
<div id="polls-168-ans" class="wp-polls-ans">
<ul class="wp-polls-ul">
<li>
<input type="radio" id="poll-answer-499" name="poll_168" value="499" />
<label for="poll-answer-499">Yes</label>
</li>
<li>
<input type="radio" id="poll-answer-500" name="poll_168" value="500" />
<label for="poll-answer-500">No</label>
</li>
<li>
<input type="radio" id="poll-answer-501" name="poll_168" value="501" />
<label for="poll-answer-501">Not sure</label>
</li>
</ul>
<div class="footer">
<input type="button" name="vote" value="Vote" class="tri-button" onclick="poll_vote(168);" />
<a href="#ViewPollResults" class="tri-button" onclick="poll_result(168); return false;" title="View Results Of This Poll">View Results</a>
</div>
</div>
</form>
</div>
<a href="http://thetriangle.org/pollsarchive" class="tri-button">Polls Archive</a></div><div id="tx_social_widget-3" class="sidebar-item widget_tx_social_widget"><div class="sidebar-title">Follow us</div><ul class="social-links">
<li class="social-item">
<i class="fa fa-facebook" style="color: #3b5998;"></i>
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">Drexel Triangle</a>
</li>
<li class="social-item">
<i class="fa fa-twitter" style="color: #00acee;"></i>
<a href="https://twitter.com/drexeltriangle" target="_blank">@DrexelTriangle</a>
</li>
<li class="social-item">
<i class="fa fa-instagram text-instagram"></i>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">@drexeltriangle</a>
</li>
<li class="social-item">
<i class="fa fa-youtube-play" style="color: #e52d27;"></i>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">DrexelTriangle</a>
</li>
</ul></div> <div class="ad-container-medium-rectangle">
<div id="538119722_INSERT_SLOT_ID_HERE" style="width:300px;height:250px;margin:0;padding:0">
<noscript><iframe id="a79c035e7a" name="a79c035e7a" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119722&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119722&cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119722_INSERT_SLOT_ID_HERE",
     auid: "538119722"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script></div> </aside>
</div>
<div class="ad-container-banner-bottom">
<div id="538317146_INSERT_SLOT_ID_HERE" style="width:728px;height:90px;margin:0;padding:0">
<noscript><iframe id="9e6e8ebf9f" name="9e6e8ebf9f" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538317146&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538317146&cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538317146_INSERT_SLOT_ID_HERE",
     auid: "538317146"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div></div>
<footer id="colophon" class="footer-wrapper">
<div class="footer-container">
<div class="footer-branding">
<div class="footer-logo">
<a href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1//images/logo-black.svg"></img>
</a>
</div>
<div class="footer-social">
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #3b5998;"></i>
<i class="fa fa-facebook fa-stack-1x"></i>
</span>
</a>
<a href="https://twitter.com/drexeltriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #00acee;"></i>
<i class="fa fa-twitter fa-stack-1x"></i>
</span>
</a>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x text-instagram"></i>
<i class="fa fa-instagram fa-stack-1x"></i>
</span>
</a>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #e52d27;"></i>
<i class="fa fa-youtube-play fa-stack-1x"></i>
</span>
</a>
<a href="https://thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&id=7389750c95" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #07294D;"></i>
<i class="fa fa-envelope-o fa-stack-1x"></i>
</span>
</a>
</div>
<div class="footer-tagline">
THE INDEPENDENT STUDENT NEWSPAPER AT DREXEL UNIVERSITY SINCE 1926
</div>
</div>
<nav class="footer-nav-container"><ul id="menu-footer-menu" class="footer-nav-links"><li id="menu-item-43823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-43823"><a href="https://www.thetriangle.org">Home</a></li>
<li id="menu-item-43824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43824"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-43826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43826"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-43827" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43827"><a href="https://www.thetriangle.org/entertainment/">A&#038;E</a></li>
<li id="menu-item-43825" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43825"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-46975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46975"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-43828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43828"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-43831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43831"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-43829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43829"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-43830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43830"><a href="https://www.thetriangle.org/join/">Join</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></nav> </div>
<div class="footer-copyright">
&copy2019 The Triangle. All rights are reserved, except where otherwise noted.
</div>
<div class="footer-disclaimer">
The Triangle is an independent student organization and is not owned nor operated by Drexel University.
</div>
</footer>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.thetriangle.org\/entertainment\/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday\/":47938};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.thetriangle.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"triangle"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"47938 https:\/\/www.thetriangle.org\/?p=47938","disqusShortname":"triangle","disqusTitle":"A look at the negative buzz around Captain Marvel ahead of its release this Friday","disqusUrl":"https:\/\/www.thetriangle.org\/entertainment\/a-look-at-the-negative-buzz-around-captain-marvel-ahead-of-its-release-this-friday\/","postId":"47938"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201910'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.thetriangle.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"0","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1/js/jquery.viewport.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1/js/search.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.1/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/comment-reply.min.js?ver=5.1'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.1.1'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/wp-embed.min.js?ver=5.1'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/modules/theme-tools/responsive-videos/responsive-videos.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.1.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201910.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'21775326',post:'47938',tz:'-5',srv:'www.thetriangle.org'} ]);
	_stq.push([ 'clickTrackerInit', '21775326', '47938' ]);
</script>
</body>
</html>
