<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="user-scalable=no width=device-width, initial-scale=1">
<script src="/cdn-cgi/apps/head/f-4CGQCrMUnIW19Y6lKMzArTWjQ.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css" />

<link rel="manifest" href="/superpwa-manifest.json">
<meta name="theme-color" content="#07294d">
<link rel="apple-touch-icon" sizes="192x192" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-192x192.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-512x512.png">


<title>Week 10 Fantasy Recap - The Triangle</title>
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Week 10 Fantasy Recap" />
<meta property="og:description" content="&nbsp; Week 10 Fantasy Outliers QB: Kyler Murray, Arizona Cardinals, 30.9 fantasy points  As we approach Week 10, we begin to talk about season accolades&hellip;" />
<meta property="og:url" content="https://www.thetriangle.org/sports/week-10-fantasy-recap/" />
<meta property="og:site_name" content="The Triangle" />
<meta property="article:publisher" content="https://www.facebook.com/drexel.triangle/" />
<meta property="article:published_time" content="2020-11-20T19:47:43+00:00" />
<meta property="og:image" content="https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped-255x300.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@thetriangle" />
<meta name="twitter:site" content="@thetriangle" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.thetriangle.org/#website","url":"https://www.thetriangle.org/","name":"The Triangle","description":"The Independent Student Newspaper at Drexel University","potentialAction":[{"@type":"SearchAction","target":"https://www.thetriangle.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.thetriangle.org/sports/week-10-fantasy-recap/#primaryimage","inLanguage":"en-US","url":"https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped.jpg","width":613,"height":720,"caption":"Kyler Murray (By All-Pro Reels -Flickr)"},{"@type":"WebPage","@id":"https://www.thetriangle.org/sports/week-10-fantasy-recap/#webpage","url":"https://www.thetriangle.org/sports/week-10-fantasy-recap/","name":"Week 10 Fantasy Recap - The Triangle","isPartOf":{"@id":"https://www.thetriangle.org/#website"},"primaryImageOfPage":{"@id":"https://www.thetriangle.org/sports/week-10-fantasy-recap/#primaryimage"},"datePublished":"2020-11-20T19:47:43+00:00","dateModified":"2020-11-20T19:47:43+00:00","author":{"@id":"https://www.thetriangle.org/#/schema/person/6c3645c97bdfebbcb11ef04c1fe31c9a"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.thetriangle.org/sports/week-10-fantasy-recap/"]}]},{"@type":["Person"],"@id":"https://www.thetriangle.org/#/schema/person/6c3645c97bdfebbcb11ef04c1fe31c9a","name":"stefan.kusmirek@thetriangle.org","image":{"@type":"ImageObject","@id":"https://www.thetriangle.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4fb140a380dc25dd9b67bd920eb1be25?s=96&d=mm&r=g","caption":"stefan.kusmirek@thetriangle.org"}}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Feed" href="https://www.thetriangle.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Comments Feed" href="https://www.thetriangle.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Week 10 Fantasy Recap Comments Feed" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thetriangle.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.thetriangle.org/wp-includes/css/dist/block-library/style.min.css?ver=5.4.4' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='flytedesk-digital-css' href='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.thetriangle.org/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='triangle-x-style-css' href='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/style.css?ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='authorizer-public-css-css' href='https://www.thetriangle.org/wp-content/plugins/authorizer/css/authorizer-public.css?ver=2.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=8.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/css/jetpack.css?ver=8.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8310cb-bac8-481b-88b4-5c347d3aea8f"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var auth = {"wpLoginUrl":"https:\/\/www.thetriangle.org\/square?redirect_to=%2Fsports%2Fweek-10-fantasy-recap%2F","publicWarning":"","anonymousNotice":"Notice: You are browsing this site anonymously, and only have access to a portion of its content.","logIn":"Log In"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/authorizer/js/authorizer-public.js?ver=2.8.0'></script>
<link rel='https://api.w.org/' href='https://www.thetriangle.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thetriangle.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thetriangle.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.4" />
<link rel='shortlink' href='https://wp.me/p1tmKW-dSM' />
<link rel="alternate" type="application/json+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fsports%2Fweek-10-fantasy-recap%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fsports%2Fweek-10-fantasy-recap%2F&#038;format=xml" />

<link rel="icon" type="image/x-icon" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle.ico">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76.png">
<link rel="apple-touch-icon-precomposed" sizes="180x180" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60.png">
<link rel="apple-touch-icon-precomposed" sizes="80x80" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="40x40" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40.png">
<link rel="apple-touch-icon-precomposed" sizes="87x87" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="58x58" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="29x29" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small.png">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-162588-4"></script>
<script>
	window.dataLayer = window.dataLayer || [];
	function gtag(){dataLayer.push(arguments);}
	gtag('js', new Date());

	gtag('config', 'UA-162588-4');
	</script>
<style type='text/css'>img#wpstats{display:none}</style> <meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.thetriangle.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '38dcdf59-7ae4-4794-90ed-5b29d7d04635';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "The Triangle";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.thetriangle.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.55479a10-4eda-4299-901a-290da3fd1836";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
</head>
<body>
<header id="header-global" class="header-global" role="banner">
<div id="header-search-icon" class="header-search-icon white">
<i class="material-icons md-36">search</i>
</div>
<div class="search-container">
<form role="search" method="get" class="search-form" action="https://www.thetriangle.org">
<input id="searchbox-main" type="search" class="search-textbox" placeholder="Search..." value="" name="s">
</form>
</div>
<div class="header-logo">
<div class="header-logo-desktop">
<a id="triangle-logo" href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-white.svg"></img> 
</a>
</div>
<a id="menu-notif" style="color: white; font-size: 12px; right: 60px; position: absolute;">Menu</a>
</div>
<div class="header-logo-mobile">
<div class="img-container">
<a href="https://www.thetriangle.org/" rel="home"><img id="logo-mobile" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/tri-icon.png"></img></a>
</div>
</div>
<div id="nav-icon" class="header-hamburger-icon white"><span></span><span></span><span></span></div>
</header>
<div id="nav-main" class="header-nav-container">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="main"><li id="menu-item-40351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40351"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-40353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40353"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-40350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40350"><a href="https://www.thetriangle.org/entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-40352" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40352"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-51695" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51695"><a href="https://www.thetriangle.org/candp/comics/">Comics</a></li>
<li id="menu-item-50768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50768"><a href="https://www.thetriangle.org/podcasts/">Podcasts</a></li>
</ul></div><div class="menu-sub-menu-container"><ul id="menu-sub-menu" class="sub"><li id="menu-item-46974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46974"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-40358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40358"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-46705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46705"><a href="https://www.thetriangle.org/join/">Join The Triangle</a></li>
<li id="menu-item-52933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52933"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-40356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40356"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-40355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40355"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-40357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40357"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></div></div>
<div class="generic-wrapper">
<title>Week 10 Fantasy Recap | The Triangle</title>
<div class="ad-container-banner-top"><div class="flytead leaderboard 8d3354da-c6b7-46ed-9d8f-77c4b0c53e7c"></div></div>
<div class="generic-container" style="margin-bottom: 0px;">
<div class="print-logo"><img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/images/logo-black.svg"></img></div>
<div class="single-title">
<h1>Week 10 Fantasy Recap</h1> </div>
<div class="single-meta">
<div class="author">By <a href="https://www.thetriangle.org/author/eli-baylin/" title="Posts by Eli Baylin" class="author url fn" rel="author">Eli Baylin</a></div>
<div class="date">Nov. 20, 2020</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-53368" class="share-facebook sd-button share-icon no-text" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-53368" class="share-twitter sd-button share-icon no-text" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-53368" class="share-linkedin sd-button share-icon no-text" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.thetriangle.org/sports/week-10-fantasy-recap/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
</div>
<div id="post-53368" class="generic-flex-container">
<main id="content" class="flex-main">
<article class="single-content">
<p>&nbsp;</p>
<figure id="attachment_53369" aria-describedby="caption-attachment-53369" style="width: 275px" class="wp-caption aligncenter"><img class=" wp-image-53369 jetpack-lazy-image" src="https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped-255x300.jpg" alt width="275" height="324" data-lazy-srcset="https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped-255x300.jpg 255w, https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped.jpg 613w" data-lazy-sizes="(max-width: 275px) 100vw, 275px" data-lazy-src="https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped-255x300.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class=" wp-image-53369" src="https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped-255x300.jpg" alt="" width="275" height="324" srcset="https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped-255x300.jpg 255w, https://www.thetriangle.org/wp-content/uploads/2020/11/613px-Kyler_Murray_in_huddle_50369475187_cropped_cropped.jpg 613w" sizes="(max-width: 275px) 100vw, 275px" /></noscript><figcaption id="caption-attachment-53369" class="wp-caption-text">Kyler Murray (By All-Pro Reels -Flickr)</figcaption></figure>
<p><span style="font-weight: 400">Week 10 Fantasy Outliers</span></p>
<p><span style="font-weight: 400">QB: Kyler Murray, Arizona Cardinals, 30.9 fantasy points </span></p>
<p><span style="font-weight: 400">As we approach Week 10, we begin to talk about season accolades and, obviously the most important one, the MVP award. Kyler Murray, or “Murray Magic,” threw a game-winning Hail Mary pass late Sunday afternoon with the clock reading triple zeros. Murray led the Cardinals to a key win over the Buffalo Bills to move to 6-3 and tie for first place in the NFC West with the Seahawks and Rams. Murray’s legs have caught eyes from all around the league. He has proven to many that he is a double-threat quarterback that can run not only under pressure but from a set play. He once again showed us Sunday as he rushed for 61 yards and two touchdowns. Beyond his run, Kyler threw for 245 yards against a solid Bills secondary and one touchdown to DeAndre Hopkins to send the Bills back to Buffalo.</span></p>
<p><span style="font-weight: 400">RB: Josh Jacobs, Las Vegas Raiders, 29.6 fantasy points</span></p>
<p><span style="font-weight: 400">Josh Jacobs probably had his second-best game of the 2020 season this week, following Week 1 where he had three touchdowns. Yesterday, he had two and rushed for his second-highest yardage this season with 112 yards. Jacobs had 21 attempts on the ground and did not disappoint because he averaged 5.3 yards per carry. The Raider big back made an impact through the air as well as he caught all four of his targets for 24 yards. He looks to continue this next week as he faces a tough matchup against Kansas City in a primetime Sunday Night Football game.</span></p>
<p><span style="font-weight: 400">WR: DeAndre Hopkins, Arizona Cardinals, 25.7 fantasy points</span></p>
<p><span style="font-weight: 400">Whenever a receiver catches a Hail Mary game-winner, I have to write about them and give them the credit they deserve. This was not your lucky Hail Mary catch though — this took skill. DeAndre &#8220;D-Hop&#8221; Hopkins brought in a 43-yard pass over three defenders, who all had a good position on the ball and who are Buffalo’s best defenders. The grab immediately went down as a “Moss” play, referencing the all-time great catcher Randy Moss, and possibly one of the best catches of all time. So that went for a touchdown to win and his seventh reception of the game. D-Hop had 127 total yards, which is no surprise, but he needed a bounce-back game from Week 9 where he only caught three receptions for 30 yards. He won this game for Arizona, point-blank.</span></p>
<p><span style="font-weight: 400">D/ST: Indianapolis Colts, 12 fantasy points</span></p>
<p><span style="font-weight: 400">Indianapolis faced off against the Tennessee Titans who have stars all around their offense. But the Indianapolis defense has proven they can’t take tough offensives; after all, they were ranked the number one defense coming into Week 10 and still came out of it on top. To begin, the Colts have not let up 30 or more points to an opposing offense all year. They also have five total defensive touchdowns. They held star wideout, AJ Brown, to just one reception and running back Derrick Henry to zero touchdowns and just over 103 yards. The Colts also blocked a punt and returned it for a touchdown. They have a huge matchup against Green Bay next week. Can their defense show out again and shut down Rodgers and the Packers?</span></p>
<p>&nbsp;</p>
</article>
<div id="comments" class="single-comments">
<div id="disqus_thread"></div>
</div>
</main>
<aside id="sidebar" class="flex-sidebar">
<div class="ad-container-medium-rectangle"><div class="flytead rectangle 8b8310cb-e928-4379-95c5-5edd76144fcf"></div></div> <div id="tx_mailchimp_newsletter-3" class="sidebar-item widget_tx_mailchimp_newsletter"><div class="sidebar-title">Sign up for our newsletter</div><p>Get The Triangle's top stories directly to your inbox every Friday</p> <div id="mc_embed_signup">
<form action="//thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&amp;id=7389750c95" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="mc-field-group">
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="email@example.com">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_6eb4aab81745d3436b16a6181_7389750c95" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div><div id="polls-widget-3" class="sidebar-item widget_polls-widget"><div class="sidebar-title">Weekly Poll</div><div id="polls-170" class="wp-polls">
<h1>What Drexel dorm hall should be knocked down first?</h1>
<div id="polls-170-ans" class="wp-polls-ans">
<ul class="wp-polls-ul">
<li>Myers
<small>(52%, 26 Votes)</small>
<div class="pollbar" style="width: 52%;" title="Myers (52% | 26 Votes)"></div>
</li>
<li>Kelly
<small>(24%, 12 Votes)</small>
<div class="pollbar" style="width: 24%;" title="Kelly (24% | 12 Votes)"></div>
</li>
<li>Towers
<small>(10%, 5 Votes)</small>
<div class="pollbar" style="width: 10%;" title="Towers (10% | 5 Votes)"></div>
</li>
<li>Van Rensselaer
<small>(10%, 5 Votes)</small>
<div class="pollbar" style="width: 10%;" title="Van Rensselaer (10% | 5 Votes)"></div>
</li>
<li>Millennium
<small>(2%, 1 Votes)</small>
<div class="pollbar" style="width: 2%;" title="Millennium (2% | 1 Votes)"></div>
</li>
<li>Race
<small>(2%, 1 Votes)</small>
<div class="pollbar" style="width: 2%;" title="Race (2% | 1 Votes)"></div>
</li>
<li>Bentley
<small>(0%, 0 Votes)</small>
<div class="pollbar" style="width: 1%;" title="Bentley (0% | 0 Votes)"></div>
</li>
<li>Caneris
<small>(0%, 0 Votes)</small>
<div class="pollbar" style="width: 1%;" title="Caneris (0% | 0 Votes)"></div>
</li>
<li>North
<small>(0%, 0 Votes)</small>
<div class="pollbar" style="width: 1%;" title="North (0% | 0 Votes)"></div>
</li>
</ul>
<div class="footer">
<h2 class="total-voters">Votes: 50</h2>
</div>
</div>
<input type="hidden" id="poll_170_nonce" name="wp-polls-nonce" value="ec2cd1a1e7" />
</div>
<a href="http://thetriangle.org/pollsarchive" class="tri-button">Polls Archive</a></div><div id="tx_social_widget-3" class="sidebar-item widget_tx_social_widget"><div class="sidebar-title">Follow us</div><ul class="social-links">
<li class="social-item">
<i class="fa fa-facebook" style="color: #3b5998;"></i>
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">Drexel Triangle</a>
</li>
<li class="social-item">
<i class="fa fa-twitter" style="color: #00acee;"></i>
<a href="https://twitter.com/drexeltriangle" target="_blank">@DrexelTriangle</a>
</li>
<li class="social-item">
<i class="fa fa-instagram text-instagram"></i>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">@drexeltriangle</a>
</li>
<li class="social-item">
<i class="fa fa-youtube-play" style="color: #e52d27;"></i>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">DrexelTriangle</a>
</li>
</ul></div> <div class="ad-container-medium-rectangle">

<div id="538119722_INSERT_SLOT_ID_HERE" style="width:300px;height:250px;margin:0;padding:0">
<noscript><iframe id="a79c035e7a" name="a79c035e7a" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119722&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119722&cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119722_INSERT_SLOT_ID_HERE",
     auid: "538119722"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div> </aside>
</div>
<div class="ad-container-banner-bottom">

<div id="538317146_INSERT_SLOT_ID_HERE" style="width:728px;height:90px;margin:0;padding:0">
<noscript><iframe id="9e6e8ebf9f" name="9e6e8ebf9f" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538317146&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538317146&cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538317146_INSERT_SLOT_ID_HERE",
     auid: "538317146"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div></div>
<footer id="colophon" class="footer-wrapper">
<div class="footer-container">
<div class="footer-branding">
<div class="footer-logo">
<a href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-black.svg"></img>
</a>
</div>
<div class="footer-social">
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #3b5998;"></i>
<i class="fa fa-facebook fa-stack-1x"></i>
</span>
</a>
<a href="https://twitter.com/drexeltriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #00acee;"></i>
<i class="fa fa-twitter fa-stack-1x"></i>
</span>
</a>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x text-instagram"></i>
<i class="fa fa-instagram fa-stack-1x"></i>
</span>
</a>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #e52d27;"></i>
<i class="fa fa-youtube-play fa-stack-1x"></i>
</span>
</a>
<a href="https://thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&id=7389750c95" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #07294D;"></i>
<i class="fa fa-envelope-o fa-stack-1x"></i>
</span>
</a>
</div>
<div class="footer-tagline">
THE INDEPENDENT STUDENT NEWSPAPER AT DREXEL UNIVERSITY SINCE 1926
</div>
</div>
<nav class="footer-nav-container"><ul id="menu-footer-menu" class="footer-nav-links"><li id="menu-item-43823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-43823"><a href="https://www.thetriangle.org">Home</a></li>
<li id="menu-item-43824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43824"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-43826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43826"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-43827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43827"><a href="https://www.thetriangle.org/entertainment/">A&#038;E</a></li>
<li id="menu-item-43825" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43825"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-46975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46975"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-43828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43828"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-43829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43829"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-43830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43830"><a href="https://www.thetriangle.org/join/">Join</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></nav> </div>
<div class="footer-copyright">
&copy2020 The Triangle. All rights are reserved, except where otherwise noted.
</div>
<div class="footer-disclaimer">
The Triangle is an independent student organization and is not owned nor operated by Drexel University.
</div>
</footer>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.thetriangle.org\/sports\/week-10-fantasy-recap\/":53368};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.thetriangle.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"triangle"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"53368 https:\/\/www.thetriangle.org\/?p=53368","disqusShortname":"triangle","disqusTitle":"Week 10 Fantasy Recap","disqusUrl":"https:\/\/www.thetriangle.org\/sports\/week-10-fantasy-recap\/","postId":"53368"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.thetriangle.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"0","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/jquery.viewport.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/search.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/comment-reply.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=8.8.2'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/wp-embed.min.js?ver=5.4.4'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.4.4' async='async'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.8.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202047.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.2',blog:'21775326',post:'53368',tz:'-5',srv:'www.thetriangle.org'} ]);
	_stq.push([ 'clickTrackerInit', '21775326', '53368' ]);
</script>
</body>
</html>
