<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" />
<script src="/cdn-cgi/apps/head/f-4CGQCrMUnIW19Y6lKMzArTWjQ.js"></script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,d,_,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),z=parseInt(__ez.dot.getTargeting(t,"compid")),g=0,c=0,l=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(l)&&(void 0!==l.creative_id&&(c=l.creative_id),void 0!==l.line_item_id&&(g=l.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:d,est_revenue:_,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:z,line_item_id:g,creative_id:c,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),d=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));(void 0!==window.isAmp&&isAmp||void 0!==window.ezWp&&ezWp)&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(d+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(d)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,d){var _=e.split("/");if(__ez.dot.isDefined(e)&&3===_.length&&__ez.dot.isValid(t)){var n=_[0],r={type:"impression",impression_id:_[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==d&&(r.revenue=d),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=7', false, [], true, false, true, false);</script>
<meta name="viewport" content="user-scalable=no width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css" />

<link rel="manifest" href="/superpwa-manifest.json" />
<link rel="prefetch" href="/superpwa-manifest.json" />
<meta name="theme-color" content="#07294d" />
<meta name="mobile-web-app-capable" content="yes" />
<meta name="apple-touch-fullscreen" content="yes" />
<meta name="apple-mobile-web-app-title" content="The Triangle" />
<meta name="application-name" content="The Triangle" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="default" />
<link rel="apple-touch-icon" sizes="192x192" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-192x192.png" />
<link rel="apple-touch-icon" sizes="192x192" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-192x192.png" />
<link rel="apple-touch-icon" sizes="512x512" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-512x512.png" />
<link rel="apple-touch-icon" sizes="512x512" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-512x512.png" />

<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1" />

<title>Historic win takes the Drexel Dragons to Next Round of CAA&#39;s</title>
<meta name="description" content="The Drexel women&#39;s soccer team beat William &amp; Mary in the first round of the CAA tournament behind a historic game from Delaney Lappin." />
<link rel="canonical" href="https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Historic win takes the Drexel Dragons to Next Round of CAA&#39;s" />
<meta property="og:description" content="The Drexel women&#39;s soccer team beat William &amp; Mary in the first round of the CAA tournament behind a historic game from Delaney Lappin." />
<meta property="og:url" content="https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/" />
<meta property="og:site_name" content="The Triangle" />
<meta property="article:publisher" content="https://www.facebook.com/drexel.triangle/" />
<meta property="article:published_time" content="2022-10-31T22:43:12+00:00" />
<meta property="article:modified_time" content="2022-10-31T22:44:32+00:00" />
<meta property="og:image" content="https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg" />
<meta name="author" content="Prasham Jobanputra" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@thetriangle" />
<meta name="twitter:site" content="@thetriangle" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Prasham Jobanputra" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="5 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/","url":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/","name":"Historic win takes the Drexel Dragons to Next Round of CAA's","isPartOf":{"@id":"https://www.thetriangle.org/#website"},"primaryImageOfPage":{"@id":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/#primaryimage"},"image":{"@id":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/#primaryimage"},"thumbnailUrl":"https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg","datePublished":"2022-10-31T22:43:12+00:00","dateModified":"2022-10-31T22:44:32+00:00","author":{"@id":"https://www.thetriangle.org/#/schema/person/4f84daf974664e3098d4ace81562a00c"},"description":"The Drexel women's soccer team beat William & Mary in the first round of the CAA tournament behind a historic game from Delaney Lappin.","breadcrumb":{"@id":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/#primaryimage","url":"https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450.jpg","contentUrl":"https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450.jpg","width":1920,"height":1280},{"@type":"BreadcrumbList","@id":"https://www.thetriangle.org/news/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.thetriangle.org/"},{"@type":"ListItem","position":2,"name":"Historic win takes the Drexel Dragons to Next Round of CAA&#8217;s"}]},{"@type":"WebSite","@id":"https://www.thetriangle.org/#website","url":"https://www.thetriangle.org/","name":"The Triangle","description":"The Independent Student Newspaper at Drexel University","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.thetriangle.org/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.thetriangle.org/#/schema/person/4f84daf974664e3098d4ace81562a00c","name":"Prasham Jobanputra","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.thetriangle.org/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/bb561fecaf738b897ddc0b509bba917b?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/bb561fecaf738b897ddc0b509bba917b?s=96&d=mm&r=g","caption":"Prasham Jobanputra"},"url":"https://www.thetriangle.org/author/prasham-jobanputra/"}]}</script>

<link rel="dns-prefetch" href="//ajax.googleapis.com" />
<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<link rel="dns-prefetch" href="//s.w.org" />
<link rel="dns-prefetch" href="//v0.wordpress.com" />
<link rel="dns-prefetch" href="//pagead2.googlesyndication.com" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thetriangle.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet" id="wp-block-library-css" href="https://www.thetriangle.org/wp-includes/css/dist/block-library/style.min.css?ver=6.0.3" type="text/css" media="all" />
<style id="wp-block-library-inline-css" type="text/css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mediaelement-css" href="https://www.thetriangle.org/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16" type="text/css" media="all" />
<link rel="stylesheet" id="wp-mediaelement-css" href="https://www.thetriangle.org/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.3" type="text/css" media="all" />
<style id="global-styles-inline-css" type="text/css">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</style>
<link rel="stylesheet" id="contact-form-7-css" href="https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.4" type="text/css" media="all" />
<link rel="stylesheet" id="flytedesk-digital-css" href="https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101" type="text/css" media="all" />
<link rel="stylesheet" id="wp-polls-css" href="https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.77.0" type="text/css" media="all" />
<style id="wp-polls-inline-css" type="text/css">
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.thetriangle.org/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel="stylesheet" id="triangle-x-style-css" href="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/style.css?ver=6.0.3" type="text/css" media="all" />
<link rel="stylesheet" id="newsletter-css" href="https://www.thetriangle.org/wp-content/plugins/newsletter/style.css?ver=7.5.2" type="text/css" media="all" />
<link rel="stylesheet" id="social-logos-css" href="https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.4" type="text/css" media="all" />
<link rel="stylesheet" id="jetpack_css-css" href="https://www.thetriangle.org/wp-content/plugins/jetpack/css/jetpack.css?ver=11.4" type="text/css" media="all" />
<script type="text/javascript" id="flytedesk-digital-js-extra">
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8310cb-bac8-481b-88b4-5c347d3aea8f"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101" id="flytedesk-digital-js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js" id="jquery-js"></script>

<script type="text/javascript" src="https://www.googletagmanager.com/gtag/js?id=UA-245662741-1" id="google_gtagjs-js" async=""></script>
<script type="text/javascript" id="google_gtagjs-js-after">
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.thetriangle.org"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-245662741-1", {"anonymize_ip":true});
gtag("config", "G-XGPDXDML2B");
</script>

<link rel="https://api.w.org/" href="https://www.thetriangle.org/wp-json/" /><link rel="alternate" type="application/json" href="https://www.thetriangle.org/wp-json/wp/v2/posts/55731" /><link rel="alternate" type="application/json+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fsports%2Flappins-historic-afternoon-powers-dragons-to-next-round-of-caas%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fsports%2Flappins-historic-afternoon-powers-dragons-to-next-round-of-caas%2F&amp;format=xml" />

<meta name="generator" content="Site Kit by Google 1.85.0" /><link rel="icon" type="image/x-icon" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle.ico" />
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76@2x.png" />
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76.png" />
<link rel="apple-touch-icon-precomposed" sizes="180x180" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@3x.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@2x.png" />
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60.png" />
<link rel="apple-touch-icon-precomposed" sizes="80x80" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40@2x.png" />
<link rel="apple-touch-icon-precomposed" sizes="40x40" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40.png" />
<link rel="apple-touch-icon-precomposed" sizes="87x87" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@3x.png" />
<link rel="apple-touch-icon-precomposed" sizes="58x58" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@2x.png" />
<link rel="apple-touch-icon-precomposed" sizes="29x29" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small.png" />
<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-162588-4"></script>
<script>
	window.dataLayer = window.dataLayer || [];
	function gtag(){dataLayer.push(arguments);}
	gtag('js', new Date());

	gtag('config', 'UA-162588-4');
	</script>
<style>img#wpstats{display:none}</style>

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236" />
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com" />

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.thetriangle.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '38dcdf59-7ae4-4794-90ed-5b29d7d04635';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "The Triangle";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.thetriangle.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.55479a10-4eda-4299-901a-290da3fd1836";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css">
			.site-title a,
		.site-description {
			color: #1e73be;
		}
		</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4156537387322541" crossorigin="anonymous" type="text/javascript"></script>

<script type="text/javascript">var ezouid = "1";</script><base href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 389911;
var ezdomain = 'thetriangle.org';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":389911,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"a9c7a3fc-ffa6-459f-6e87-7e5ca9b3149f","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":60793,"response_time_orig":4,"serverid":"35.153.156.236:20212","state":"VA","t_epoch":1667365790,"template_id":120,"time_on_site_visit":0,"url":"https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/","user_id":0,"word_count":1151,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_389911=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["a9c7a3fc-ffa6-459f-6e87-7e5ca9b3149f", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div class="marquee"> <div><span id="breaking-1" class="breaking-notification">Breaking News: <a class="breaking-headline" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/">Historic win takes the Drexel Dragons to Next Round of CAA’s</a></span><span id="breaking-2" class="breaking-notification">Breaking News: <a class="breaking-headline" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/">Historic win takes the Drexel Dragons to Next Round of CAA’s</a></span></div> </div>
<header id="header-global" class="header-global" role="banner">
<div id="header-search-icon" class="header-search-icon white">
<i class="material-icons md-36">search</i>
</div>
<div class="search-container">
<form role="search" method="get" class="search-form" action="https://www.thetriangle.org">
<input id="searchbox-main" type="search" class="search-textbox" placeholder="Search..." value="" name="s" />
</form>
</div>
<div class="header-logo">
<div class="header-logo-desktop">
<a id="triangle-logo" href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-white.svg" />
</a>
</div>
<a id="menu-notif" style="color: white; font-size: 12px; right: 60px; position: absolute;">Menu</a>
</div>
<div class="header-logo-mobile">
<div class="img-container">
<a href="https://www.thetriangle.org/" rel="home"><img id="logo-mobile" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/tri-icon.png" /></a>
</div>
</div>
<div id="nav-icon" class="header-hamburger-icon white"><span></span><span></span><span></span></div>
</header>
<div id="nav-main" class="header-nav-container">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="main"><li id="menu-item-40351" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40351"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-40353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40353"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-40350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40350"><a href="https://www.thetriangle.org/entertainment/">Arts &amp; Entertainment</a></li>
<li id="menu-item-40352" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40352"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-51695" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51695"><a href="https://www.thetriangle.org/candp/comics/">Comics</a></li>
<li id="menu-item-50768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50768"><a href="https://www.thetriangle.org/podcasts/">Podcasts</a></li>
</ul></div><div class="menu-sub-menu-container"><ul id="menu-sub-menu" class="sub"><li id="menu-item-46974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46974"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-40358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40358"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-46705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46705"><a href="https://www.thetriangle.org/join-the-triangle/">Join The Triangle</a></li>
<li id="menu-item-40356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40356"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-40355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40355"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-40357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40357"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></div></div>
<div class="generic-wrapper">
<title>Historic win takes the Drexel Dragons to Next Round of CAA’s | The Triangle</title>
<div class="ad-container-banner-top"><div class="flytead leaderboard 8d3354da-c6b7-46ed-9d8f-77c4b0c53e7c"></div></div>
<div class="generic-container" style="margin-bottom: 0px;">
<div class="print-logo"><img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/images/logo-black.svg" /></div>
<div class="single-title">
<h1>Historic win takes the Drexel Dragons to Next Round of CAA’s</h1> </div>
<div class="single-meta">
<div class="author">By <a href="https://www.thetriangle.org/author/paulie-loscalzo/" title="Posts by Paulie Loscalzo" class="author url fn" rel="author">Paulie Loscalzo</a></div>
<div class="date">Oct. 31, 2022</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-55731" class="share-facebook sd-button share-icon no-text" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-55731" class="share-twitter sd-button share-icon no-text" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-55731" class="share-linkedin sd-button share-icon no-text" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.thetriangle.org/sports/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
</div>
<div id="post-55731" class="generic-flex-container">
<main id="content" class="flex-main">
<article class="single-content">
<figure class="wp-block-image size-large"><img width="1024" height="683" class="wp-image-55734 jetpack-lazy-image" src="https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg" alt="" data-lazy-srcset="https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg 1024w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-300x200.jpg 300w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-768x512.jpg 768w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1536x1024.jpg 1536w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450.jpg 1920w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><noscript><img data-lazy-fallback="1" width="1024" height="683" class="wp-image-55734" src="https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg" alt="" srcset="https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1024x683.jpg 1024w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-300x200.jpg 300w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-768x512.jpg 768w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450-1536x1024.jpg 1536w, https://www.thetriangle.org/wp-content/uploads/2022/10/2022-09-08DrexelWSocvTemple_0450.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px"  /></noscript><figcaption class="wp-element-caption"><em>Delaney Lappin broke the program’s single-season goal record with her two-goal performance in the first round of the CAA tournament. (Photo: Drexel Athletics/Sideline Photos)</em></figcaption></figure>
<p>It would not be hyperbolic to say that the 2022 Drexel University women’s soccer team is in the midst of one of their best seasons in Drexel’s history. The Dragons have surged this year reaching the postseason for the first time since 2018 on the back of an explosive offense, and on Thursday the Dragons ensured that their historic season would continue. </p><div id="ezoic-pub-ad-placeholder-102" data-inserter-version="2"></div>
<p>Throughout the regular season, Drexel had proved their mettle, dominating the regular season en route to their number two seeding in the Colonial Athletic Association playoffs with their potent offense and solid defense, demonstrated by their superb +12-goal differential. The College of William and Mary, the number seven seed, did not separate themselves much, sneaking into the playoffs by just one point and only outscoring their opponents by two goals throughout the season. The Dragons were the better team on paper, and they certainly played like it. Throughout the game, Drexel forwards Casey Touey, a sophomore, Delaney Lappin, a junior, and Isabel Kuzy, a senior, were hustling to every ball in their vicinity, bulldozing the Tribe defense with their speed and physicality. On defense, senior defender Kylie Kutz also physically dominated the Tribe’s offense, stifling every opportunity that William and Mary tried to create through the flow of the game. </p>
<p>Through most of the first half, Drexel was dominant. From kickoff, the most dangerous scoring opportunities were from the Dragons. In the 10th minute, Touey was almost able to get on the receiving end of a cross and put it in the back of the net but the cross was just high.</p><div id="ezoic-pub-ad-placeholder-110" data-inserter-version="2"></div>
<p>The Dragons kept coming after this near miss, using their speed and physicality to outplay the Tribe. Their hard work created a penalty kick when William and Mary defender Addie Puskar’s only recourse to prevent a golden scoring opportunity for Drexel was to bring down Anna Salvucci, sophomore midfielder, in the box. It appeared like this would surely result in Drexel taking the lead as the clinical Annalena O’Reilly, a senior forward, stood over the ball, however, the shot was driven on the ground and right into William and Mary’s senior goalkeeper Zoe Doughty.</p>
<p>Drexel continued creating scoring opportunities for themselves, including one shot from very close proximity for Delaney Lappin, but The Tribe were able to bend but not break. Gradually throughout the first half, the center referee, David Breckner, began calling a much tighter game, a trend that was detrimental to the Dragons as it severely impaired players such as Kuzy and Kutz from exerting their physical advantage upon their opponents. This manifested itself when the referee Breckner called a foul on Kutz in the 42nd minute. Nicole Sellers, junior defender for William and Mary, whipped in a dangerous ball to the 18 yard box that freshman forward Ivey Crain was able to flick on to the graduate student forward, Cricket Basa, who was able to tap the ball into the back of the net. This shocking goal gave William and Mary an unexpected 1-0 lead at halftime.  </p>
<p>Coming out of halftime, it was clear that the Dragons were determined to make a comeback. Within the first minute of the second half, Casey Touey nearly put away a goal on a breakaway. In the coming minutes, Drexel was all over the Tribe and appeared to be on the brink of breaking through. This finally happened in the 50th minute when Touey was able to get in on the William and Mary goal and take on multiple defenders, acting as a battering ram to get the ball inside the Tribe’s six-yard box. When William and Mary defender Nicole Sellers poked the ball away from Touey, Delaney Lappin was right there to clean up the mess, and she fired the ball into the vacant net. This goal was a special one for Lappin, not only because it tied this all-important game for the Dragons, but also because it was Lappin’s 11th goal of the season, a total which tied the Drexel single-season record. </p><div id="ezoic-pub-ad-placeholder-111" data-inserter-version="2"></div>
<p>With the game locked at one, both sides ratcheted up the intensity. William and Mary’s forwards in particular attempted to match the physical presence of Drexel’s defense. Breckner maintained control of the game by calling fouls when needed, but the energy on the field was palpable. </p>
<p>Lappin must have felt that the game was devoid of highlight worthy plays, because as the game reached the 60th minute she decided to make history in style. Gabrielle Perrotto, a junior midfielder, made a tremendous play to win a 50/50 ball and direct it towards Lappin. Lappin collected the ball, shed her defender, and fired in a shot from over 20 yards out. This goal was Lappin’s 12th score, giving her sole possession of first for the Drexel single-season goals record.</p>
<p>Drexel would have to preserve their two-to-one lead for the next 30 minutes, and, while William and Mary’s senior forward Jillian O’Toole fired a shot off the crossbar in the 72nd minute, the Dragons were able to shut down the Tribe for the remainder of the game. </p><div id="ezoic-pub-ad-placeholder-112" data-inserter-version="2"></div>
<p>With one win under their belt, the Dragons turn their focus towards Sunday, October 30th, when they will face Northeastern University in what should be a very compelling match. Northeastern are the third seeded team in the CAA playoffs and coming fresh off a two-to-one victory over Stony Brook University.</p>
</article>
<div id="comments" class="single-comments">
<div id="disqus_thread"></div>
</div>
</main>
<aside id="sidebar" class="flex-sidebar">
<div class="ad-container-medium-rectangle"><div class="flytead rectangle 8b8310cb-e928-4379-95c5-5edd76144fcf"></div></div> <div id="tx_mailchimp_newsletter-3" class="sidebar-item widget_tx_mailchimp_newsletter"><div class="sidebar-title">Sign up for our newsletter</div><p>Get The Triangle&#39;s top stories directly to your inbox every Friday</p> <div id="mc_embed_signup">
<form action="//thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&amp;id=7389750c95" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group">
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="email@example.com" />
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_6eb4aab81745d3436b16a6181_7389750c95" tabindex="-1" value="" /></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button" /></div>
</div>
</form>
</div>
</div><div id="polls-widget-3" class="sidebar-item widget_polls-widget"><div class="sidebar-title">Weekly Poll</div><div id="polls-171" class="wp-polls">
<h1>Best Pizza Place on campus?</h1>
<div id="polls-171-ans" class="wp-polls-ans">
<ul class="wp-polls-ul">
<li>Ed’s
<small>(58%, 14 Votes)</small>
<div class="pollbar" style="width: 58%;" title="Ed’s (58% | 14 Votes)"></div>
</li>
<li>Savas
<small>(25%, 6 Votes)</small>
<div class="pollbar" style="width: 25%;" title="Savas (25% | 6 Votes)"></div>
</li>
<li>Blaze
<small>(8%, 2 Votes)</small>
<div class="pollbar" style="width: 8%;" title="Blaze (8% | 2 Votes)"></div>
</li>
<li>Axis
<small>(4%, 1 Votes)</small>
<div class="pollbar" style="width: 4%;" title="Axis (4% | 1 Votes)"></div>
</li>
<li>DP Dough
<small>(4%, 1 Votes)</small>
<div class="pollbar" style="width: 4%;" title="DP Dough (4% | 1 Votes)"></div>
</li>
<li>other
<small>(0%, 0 Votes)</small>
<div class="pollbar" style="width: 1%;" title="other (0% | 0 Votes)"></div>
</li>
</ul>
<div class="footer">
<h2 class="total-voters">Votes: 24</h2>
</div>
</div>
<input type="hidden" id="poll_171_nonce" name="wp-polls-nonce" value="450934cf9e" />
</div>
<a href="http://thetriangle.org/pollsarchive" class="tri-button">Polls Archive</a></div><div id="tx_social_widget-3" class="sidebar-item widget_tx_social_widget"><div class="sidebar-title">Follow us</div><ul class="social-links">
<li class="social-item">
<i class="fa fa-facebook" style="color: #3b5998;"></i>
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">Drexel Triangle</a>
</li>
<li class="social-item">
<i class="fa fa-twitter" style="color: #00acee;"></i>
<a href="https://twitter.com/drexeltriangle" target="_blank">@DrexelTriangle</a>
</li>
<li class="social-item">
<i class="fa fa-instagram text-instagram"></i>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">@drexeltriangle</a>
</li>
<li class="social-item">
<i class="fa fa-youtube-play" style="color: #e52d27;"></i>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">DrexelTriangle</a>
</li>
</ul></div> <div class="ad-container-medium-rectangle">

<div id="538119722_INSERT_SLOT_ID_HERE" style="width:300px;height:250px;margin:0;padding:0">
<noscript><iframe id="a79c035e7a" name="a79c035e7a" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119722&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119722&cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119722_INSERT_SLOT_ID_HERE",
     auid: "538119722"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div> </aside>
</div>
<div class="ad-container-banner-bottom">

<div id="538317146_INSERT_SLOT_ID_HERE" style="width:728px;height:90px;margin:0;padding:0">
<noscript><iframe id="9e6e8ebf9f" name="9e6e8ebf9f" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538317146&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538317146&cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538317146_INSERT_SLOT_ID_HERE",
     auid: "538317146"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div></div>
<footer id="colophon" class="footer-wrapper">
<div class="footer-container">
<div class="footer-branding">
<div class="footer-logo">
<a href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-black.svg" />
</a>
</div>
<div class="footer-social">
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #3b5998;"></i>
<i class="fa fa-facebook fa-stack-1x"></i>
</span>
</a>
<a href="https://twitter.com/drexeltriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #00acee;"></i>
<i class="fa fa-twitter fa-stack-1x"></i>
</span>
</a>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x text-instagram"></i>
<i class="fa fa-instagram fa-stack-1x"></i>
</span>
</a>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #e52d27;"></i>
<i class="fa fa-youtube-play fa-stack-1x"></i>
</span>
</a>
<a href="https://thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&amp;id=7389750c95" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #07294D;"></i>
<i class="fa fa-envelope-o fa-stack-1x"></i>
</span>
</a>
</div>
<div class="footer-tagline">
THE INDEPENDENT STUDENT NEWSPAPER AT DREXEL UNIVERSITY SINCE 1926
</div>
</div>
<nav class="footer-nav-container"><ul id="menu-footer-menu" class="footer-nav-links"><li id="menu-item-43823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-43823"><a href="https://www.thetriangle.org">Home</a></li>
<li id="menu-item-43824" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43824"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-43826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43826"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-43827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43827"><a href="https://www.thetriangle.org/entertainment/">A&amp;E</a></li>
<li id="menu-item-43825" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43825"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-46975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46975"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-43828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43828"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-43829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43829"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-43830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43830"><a href="https://www.thetriangle.org/join-the-triangle/">Join</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></nav> </div>
<div class="footer-copyright">
©2022 The Triangle. All rights are reserved, except where otherwise noted.
</div>
<div class="footer-disclaimer">
The Triangle is an independent student organization and is not owned nor operated by Drexel University.
</div>
</footer>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.thetriangle.org\/sports\/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas\/":55731};
	</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/swv/js/index.js?ver=5.6.4" id="swv-js"></script>
<script type="text/javascript" id="contact-form-7-js-extra">
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.thetriangle.org\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.4" id="contact-form-7-js"></script>
<script type="text/javascript" id="disqus_count-js-extra">
/* <![CDATA[ */
var countVars = {"disqusShortname":"triangle"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22" id="disqus_count-js"></script>
<script type="text/javascript" id="disqus_embed-js-extra">
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"55731 https:\/\/www.thetriangle.org\/?p=55731","disqusShortname":"triangle","disqusTitle":"Historic win takes the Drexel Dragons to Next Round of CAA\u2019s","disqusUrl":"https:\/\/www.thetriangle.org\/sports\/lappins-historic-afternoon-powers-dragons-to-next-round-of-caas\/","postId":"55731"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22" id="disqus_embed-js"></script>
<script type="text/javascript" id="superpwa-register-sw-js-extra">
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php","disable_addtohome":"0","enableOnDesktop":""};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js" id="superpwa-register-sw-js"></script>
<script type="text/javascript" id="wp-polls-js-extra">
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.thetriangle.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"0","show_fading":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.77.0" id="wp-polls-js"></script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/jquery.viewport.js?ver=20151215" id="triangle-x-inviewport-js"></script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/navigation.js?ver=20151215" id="triangle-x-navigation-js"></script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/search.js?ver=20151215" id="triangle-x-search-js"></script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/skip-link-focus-fix.js?ver=20151215" id="triangle-x-skip-link-focus-fix-js"></script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-includes/js/comment-reply.min.js?ver=6.0.3" id="comment-reply-js"></script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&amp;ver=83ec8aa758f883d6da14" id="jetpack-lazy-images-polyfill-intersectionobserver-js"></script>
<script type="text/javascript" id="jetpack-lazy-images-js-extra">
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&amp;ver=8767d0da914b289bd862" id="jetpack-lazy-images-js"></script>
<script type="text/javascript" src="https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=6.0.3" async="async" id="remote_sdk-js"></script>
<script type="text/javascript" id="sharing-js-js-extra">
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.4" id="sharing-js-js"></script>
<script type="text/javascript" id="sharing-js-js-after">
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
</script>
<script src="https://stats.wp.com/e-202244.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'21775326',post:'55731',tz:'-4',srv:'www.thetriangle.org'} ]);
	_stq.push([ 'clickTrackerInit', '21775326', '55731' ]);
</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script type="text/javascript" data-cfasync="false"></script>
<script>var _audins_dom="thetriangle_org",_audins_did=389911;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.thetriangle_org,DomainId.389911" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=0&cb=4', false, [], true, false, true, false);</script></body></html>