<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="user-scalable=no width=device-width, initial-scale=1">
<script src="/cdn-cgi/apps/head/f-4CGQCrMUnIW19Y6lKMzArTWjQ.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css" />

<link rel="manifest" href="/superpwa-manifest.json">
<meta name="theme-color" content="#07294d">
<link rel="apple-touch-icon" sizes="192x192" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-192x192.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://www.thetriangle.org/wp-content/uploads/2018/05/tri-icon-512x512.png">

<title>Men’s Basketball loses three straight games - The Triangle</title>

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Men’s Basketball loses three straight games - The Triangle" />
<meta property="og:description" content="After three straight wins in January, including a home victory against the number one seed William &amp; Mary, it looked as if the Drexel Dragons&hellip;" />
<meta property="og:url" content="https://www.thetriangle.org/sports/drexel-mbb-week-5/" />
<meta property="og:site_name" content="The Triangle" />
<meta property="article:publisher" content="https://www.facebook.com/drexel.triangle/" />
<meta property="article:tag" content="#alexis carlsson" />
<meta property="article:tag" content="Drexel Athletics" />
<meta property="article:tag" content="Drexel Dragons" />
<meta property="article:tag" content="Drexel Men&#039;s Basketball" />
<meta property="article:tag" content="Drexel University" />
<meta property="article:section" content="Sports" />
<meta property="article:published_time" content="2020-02-07T12:00:17+00:00" />
<meta property="article:modified_time" content="2020-02-07T03:53:45+00:00" />
<meta property="og:updated_time" content="2020-02-07T03:53:45+00:00" />
<meta property="og:image" content="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg" />
<meta property="og:image:secure_url" content="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg" />
<meta property="og:image:width" content="1500" />
<meta property="og:image:height" content="844" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="After three straight wins in January, including a home victory against the number one seed William &amp; Mary, it looked as if the Drexel Dragons&hellip;" />
<meta name="twitter:title" content="Men’s Basketball loses three straight games - The Triangle" />
<meta name="twitter:site" content="@thetriangle" />
<meta name="twitter:image" content="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg" />
<meta name="twitter:creator" content="@thetriangle" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.thetriangle.org/#website","url":"https://www.thetriangle.org/","name":"The Triangle","description":"The Independent Student Newspaper at Drexel University","potentialAction":{"@type":"SearchAction","target":"https://www.thetriangle.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.thetriangle.org/sports/drexel-mbb-week-5/#primaryimage","url":"https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg","width":1500,"height":844},{"@type":"WebPage","@id":"https://www.thetriangle.org/sports/drexel-mbb-week-5/#webpage","url":"https://www.thetriangle.org/sports/drexel-mbb-week-5/","inLanguage":"en-US","name":"Men\u2019s Basketball loses three straight games - The Triangle","isPartOf":{"@id":"https://www.thetriangle.org/#website"},"primaryImageOfPage":{"@id":"https://www.thetriangle.org/sports/drexel-mbb-week-5/#primaryimage"},"datePublished":"2020-02-07T12:00:17+00:00","dateModified":"2020-02-07T03:53:45+00:00","author":{"@id":"https://www.thetriangle.org/#/schema/person/530a7bd7480dfd7ec82cc9656554a28f"}},{"@type":["Person"],"@id":"https://www.thetriangle.org/#/schema/person/530a7bd7480dfd7ec82cc9656554a28f","name":"Mark Budd","image":{"@type":"ImageObject","@id":"https://www.thetriangle.org/#authorlogo","url":"https://secure.gravatar.com/avatar/?s=96&d=mm&r=g","caption":"Mark Budd"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Feed" href="https://www.thetriangle.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Comments Feed" href="https://www.thetriangle.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Triangle &raquo; Men’s Basketball loses three straight games Comments Feed" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thetriangle.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.thetriangle.org/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='flytedesk-digital-css' href='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.4' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.thetriangle.org/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='triangle-x-style-css' href='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='authorizer-public-css-css' href='https://www.thetriangle.org/wp-content/plugins/authorizer/css/authorizer-public.css?ver=2.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.thetriangle.org/wp-content/plugins/jetpack/css/jetpack.css?ver=8.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8310cb-bac8-481b-88b4-5c347d3aea8f"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var auth = {"wpLoginUrl":"https:\/\/www.thetriangle.org\/square?redirect_to=%2Fsports%2Fdrexel-mbb-week-5%2F","publicWarning":"","anonymousNotice":"Notice: You are browsing this site anonymously, and only have access to a portion of its content.","logIn":"Log In"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/authorizer/js/authorizer-public.js?ver=2.8.0'></script>
<link rel='https://api.w.org/' href='https://www.thetriangle.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thetriangle.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thetriangle.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://wp.me/p1tmKW-diB' />
<link rel="alternate" type="application/json+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fsports%2Fdrexel-mbb-week-5%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thetriangle.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thetriangle.org%2Fsports%2Fdrexel-mbb-week-5%2F&#038;format=xml" />

<link rel="icon" type="image/x-icon" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle.ico">
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-76.png">
<link rel="apple-touch-icon-precomposed" sizes="180x180" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-60.png">
<link rel="apple-touch-icon-precomposed" sizes="80x80" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="40x40" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small-40.png">
<link rel="apple-touch-icon-precomposed" sizes="87x87" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@3x.png">
<link rel="apple-touch-icon-precomposed" sizes="58x58" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small@2x.png">
<link rel="apple-touch-icon-precomposed" sizes="29x29" href="https://www.thetriangle.org/wp-content/plugins/trifunctions/favicons/Triangle-Small.png">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-162588-4"></script>
<script>
	window.dataLayer = window.dataLayer || [];
	function gtag(){dataLayer.push(arguments);}
	gtag('js', new Date());

	gtag('config', 'UA-162588-4');
	</script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style> <meta name="onesignal" content="wordpress-plugin" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.thetriangle.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '38dcdf59-7ae4-4794-90ed-5b29d7d04635';
oneSignal_options['autoRegister'] = false;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "The Triangle";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.thetriangle.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.55479a10-4eda-4299-901a-290da3fd1836";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
</head>
<body>
<header id="header-global" class="header-global" role="banner">
<div id="header-search-icon" class="header-search-icon white">
<i class="material-icons md-36">search</i>
</div>
<div class="search-container">
<form role="search" method="get" class="search-form" action="https://www.thetriangle.org">
<input id="searchbox-main" type="search" class="search-textbox" placeholder="Search..." value="" name="s">
</form>
</div>
<div class="header-logo">
<div class="header-logo-desktop">
<a id="triangle-logo" href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-white.svg"></img>
</a>
</div>
<a id="menu-notif" style="color: white; font-size: 12px; right: 60px; position: absolute;">Menu</a>
</div>
<div class="header-logo-mobile">
<div class="img-container">
<a href="https://www.thetriangle.org/" rel="home"><img id="logo-mobile" src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/tri-icon.png"></img></a>
</div>
</div>
<div id="nav-icon" class="header-hamburger-icon white"><span></span><span></span><span></span></div>
</header>
<div id="nav-main" class="header-nav-container">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="main"><li id="menu-item-40351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40351"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-40353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40353"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-40350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40350"><a href="https://www.thetriangle.org/entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-40352" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40352"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-50768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50768"><a href="https://www.thetriangle.org/podcasts/">Podcasts</a></li>
</ul></div><div class="menu-sub-menu-container"><ul id="menu-sub-menu" class="sub"><li id="menu-item-46974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46974"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-40358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40358"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-46705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46705"><a href="https://www.thetriangle.org/join/">Join The Triangle</a></li>
<li id="menu-item-40354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40354"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-40356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40356"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-40355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40355"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-40357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40357"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></div></div>
<div class="generic-wrapper">
<title>Men’s Basketball loses three straight games | The Triangle</title>
<div class="ad-container-banner-top"><div class="flytead leaderboard 8d3354da-c6b7-46ed-9d8f-77c4b0c53e7c"></div></div>
<div class="generic-container" style="margin-bottom: 0px;">
<div class="print-logo"><img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/images/logo-black.svg"></img></div>
<div class="single-title">
<h1>Men’s Basketball loses three straight games</h1> </div>
<div class="single-meta">
<div class="author">By <a href="https://www.thetriangle.org/author/mark-budd/" title="Posts by Mark Budd" class="author url fn" rel="author">Mark Budd</a></div>
<div class="date">Feb. 7, 2020</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-51125" class="share-facebook sd-button share-icon no-text" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-51125" class="share-twitter sd-button share-icon no-text" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-51125" class="share-linkedin sd-button share-icon no-text" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.thetriangle.org/sports/drexel-mbb-week-5/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
</div>
<div id="post-51125" class="generic-flex-container">
<main id="content" class="flex-main">
<article class="single-content">
<figure id="attachment_51128" aria-describedby="caption-attachment-51128" style="width: 1500px" class="wp-caption alignnone"><img class="size-full wp-image-51128 jetpack-lazy-image" src="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg" alt width="1500" height="844" data-lazy-srcset="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg 1500w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-300x169.jpg 300w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-1024x576.jpg 1024w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-768x432.jpg 768w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-1280x720.jpg 1280w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-800x450.jpg 800w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-400x225.jpg 400w" data-lazy-sizes="(max-width: 1500px) 100vw, 1500px" data-lazy-src="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="size-full wp-image-51128" src="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg" alt="" width="1500" height="844" srcset="https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5.jpg 1500w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-300x169.jpg 300w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-1024x576.jpg 1024w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-768x432.jpg 768w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-1280x720.jpg 1280w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-800x450.jpg 800w, https://www.thetriangle.org/wp-content/uploads/2020/02/mbbwk5-400x225.jpg 400w" sizes="(max-width: 1500px) 100vw, 1500px" /></noscript><figcaption id="caption-attachment-51128" class="wp-caption-text">Drexel men’s basketball guard Camren Wynter (above) talks to the team during a game against University of Delaware, where the Blue Hens won 80-72 (Photograph courtesy of Ryan Samson).</figcaption></figure>
<p>After three straight wins in January, including a home victory against the number one seed William &amp; Mary, it looked as if the Drexel Dragons men’s basketball team was making a push to be considered contenders for the Colonial Athletic Association championship.</p>
<p>Unfortunately though, since the Jan. 18 win against William &amp; Mary, the Dragons have lost three games straight to Northeastern University, Hofstra University and most recently University of Delaware. Before this streak, the Dragons faced the Blue Hens at home on Jan. 3, 2020, Drexel came away with a 61-55 win behind Camren Wynters 18 points. This time around the Dragons traveled to Newark, Delaware on Feb. 1 looking for a similar result.</p>
<p>In the first half, the Dragons had their hands full with Delaware junior Nate Darling, who scored 17 first-half points, including three 3-pointers. Darling managed only eight points against the Dragons the first time around and was clearly motivated to bring his best for round two. Darling showed why he is averaging 20 points, four rebounds and three assists on the season.</p>
<p>He wasn’t the only Blue Hen that the Dragons struggled to contain in the first half, as sophomore Kevin Anderson scored 10 points in the first half. For the game, Anderson finished with 20 points, four rebounds and two assists.</p>
<p>The Blue Hens controlled the pace in the first half outscoring Drexel 38-29. The Dragons struggled defensively as they allowed Delaware to make 53 percent of their shots.</p>
<p>Delaware continued to dominate the Dragons in the second half, but the Dragons were not going to go down without a strong fight. Delaware went up by as much as 16 points with five minutes to go. Drexel responded with a 13 to four run to get the game within six with one minute and 36 seconds to go. Unfortunately for the Dragons, they could not capitalize on their comeback attempt, and they never got any closer. The final score of the game was  80-72. There was a substantial gap in the shooting statistics categories between the Dragons and Blue Hens.</p>
<p>The Blue Hens shot 52 percent from three compared to Drexels 44 percent. Delaware also connected on 39 percent of their shots from downtown compared to the Dragons 28 percent. Drexel’s biggest issue was containing the scoring combination of Anderson, Junior Dylan Painter and Darling. Painter finished the game shooting a perfect 7-7 from the field finishing with 20 points and 10 rebounds. Sterling stole the show finishing with 27 points, including four 3-pointers.</p>
<p>Despite the loss, Camryn Wynter continues to show out for the Dragons as he finished the game with 22 points and four assists. Junior James Butler had himself a night as he went for his fifteenth double-double of the season finishing with 18 points.</p>
<p>Saturday’s loss to Delaware puts the Dragons in sixth place of the CAA conference with an overall record of (12-11, 5-5 CAA). Drexel has eight games remaining to make move up the CAA Standings. This has been an up and down season for the Dragons considering less than a month ago they were in third place of the CAA conference.</p>
</article>
<div id="comments" class="single-comments">
<div id="disqus_thread"></div>
</div>
</main>
<aside id="sidebar" class="flex-sidebar">
<div class="ad-container-medium-rectangle"><div class="flytead rectangle 8b8310cb-e928-4379-95c5-5edd76144fcf"></div></div> <div id="tx_mailchimp_newsletter-3" class="sidebar-item widget_tx_mailchimp_newsletter"><div class="sidebar-title">Sign up for our newsletter</div><p>Get The Triangle's top stories directly to your inbox every Friday</p> <div id="mc_embed_signup">
<form action="//thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&amp;id=7389750c95" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="mc-field-group">
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="email@example.com">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_6eb4aab81745d3436b16a6181_7389750c95" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div><div id="polls-widget-3" class="sidebar-item widget_polls-widget"><div class="sidebar-title">Weekly Poll</div><div id="polls-168" class="wp-polls">
<form id="polls_form_168" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_168_nonce" name="wp-polls-nonce" value="d18f5d82d9" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="168" /></p>
<h1>Do you think more could be done at Drexel to address discrimination?</h1>
<div id="polls-168-ans" class="wp-polls-ans">
<ul class="wp-polls-ul">
<li>
<input type="radio" id="poll-answer-499" name="poll_168" value="499" />
<label for="poll-answer-499">Yes</label>
</li>
<li>
<input type="radio" id="poll-answer-500" name="poll_168" value="500" />
<label for="poll-answer-500">No</label>
</li>
<li>
<input type="radio" id="poll-answer-501" name="poll_168" value="501" />
<label for="poll-answer-501">Not sure</label>
</li>
</ul>
<div class="footer">
<input type="button" name="vote" value="Vote" class="tri-button" onclick="poll_vote(168);" />
<a href="#ViewPollResults" class="tri-button" onclick="poll_result(168); return false;" title="View Results Of This Poll">View Results</a>
</div>
</div>
</form>
</div>
<a href="http://thetriangle.org/pollsarchive" class="tri-button">Polls Archive</a></div><div id="tx_social_widget-3" class="sidebar-item widget_tx_social_widget"><div class="sidebar-title">Follow us</div><ul class="social-links">
<li class="social-item">
<i class="fa fa-facebook" style="color: #3b5998;"></i>
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">Drexel Triangle</a>
</li>
<li class="social-item">
<i class="fa fa-twitter" style="color: #00acee;"></i>
<a href="https://twitter.com/drexeltriangle" target="_blank">@DrexelTriangle</a>
</li>
<li class="social-item">
<i class="fa fa-instagram text-instagram"></i>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">@drexeltriangle</a>
</li>
<li class="social-item">
<i class="fa fa-youtube-play" style="color: #e52d27;"></i>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">DrexelTriangle</a>
</li>
</ul></div> <div class="ad-container-medium-rectangle">

<div id="538119722_INSERT_SLOT_ID_HERE" style="width:300px;height:250px;margin:0;padding:0">
<noscript><iframe id="a79c035e7a" name="a79c035e7a" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538119722&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538119722&cs=a79c035e7a&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538119722_INSERT_SLOT_ID_HERE",
     auid: "538119722"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div> </aside>
</div>
<div class="ad-container-banner-bottom">

<div id="538317146_INSERT_SLOT_ID_HERE" style="width:728px;height:90px;margin:0;padding:0">
<noscript><iframe id="9e6e8ebf9f" name="9e6e8ebf9f" src="//oncampusweb-d.openx.net/w/1.0/afr?auid=538317146&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90"><a href="//oncampusweb-d.openx.net/w/1.0/rc?cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" ><img src="//oncampusweb-d.openx.net/w/1.0/ai?auid=538317146&cs=9e6e8ebf9f&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a></iframe></noscript>
</div>
<script type="text/javascript">
  var OX_ads = OX_ads || [];
  OX_ads.push({
     slot_id: "538317146_INSERT_SLOT_ID_HERE",
     auid: "538317146"
  });
</script>
<script type="text/javascript" src="//oncampusweb-d.openx.net/w/1.0/jstag"></script>
</div></div>
<footer id="colophon" class="footer-wrapper">
<div class="footer-container">
<div class="footer-branding">
<div class="footer-logo">
<a href="https://www.thetriangle.org/" rel="home">
<img src="https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2//images/logo-black.svg"></img>
</a>
</div>
<div class="footer-social">
<a href="https://www.facebook.com/drexel.triangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #3b5998;"></i>
<i class="fa fa-facebook fa-stack-1x"></i>
</span>
</a>
<a href="https://twitter.com/drexeltriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #00acee;"></i>
<i class="fa fa-twitter fa-stack-1x"></i>
</span>
</a>
<a href="https://www.instagram.com/drexeltriangle/" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x text-instagram"></i>
<i class="fa fa-instagram fa-stack-1x"></i>
</span>
</a>
<a href="https://www.youtube.com/user/DrexelTriangle" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #e52d27;"></i>
<i class="fa fa-youtube-play fa-stack-1x"></i>
</span>
</a>
<a href="https://thetriangle.us2.list-manage.com/subscribe/post?u=6eb4aab81745d3436b16a6181&id=7389750c95" target="_blank">
<span class="fa-stack fa-1x">
<i class="fa fa-circle fa-stack-2x" style="color: #07294D;"></i>
<i class="fa fa-envelope-o fa-stack-1x"></i>
</span>
</a>
</div>
<div class="footer-tagline">
THE INDEPENDENT STUDENT NEWSPAPER AT DREXEL UNIVERSITY SINCE 1926
</div>
</div>
<nav class="footer-nav-container"><ul id="menu-footer-menu" class="footer-nav-links"><li id="menu-item-43823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-43823"><a href="https://www.thetriangle.org">Home</a></li>
<li id="menu-item-43824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43824"><a href="https://www.thetriangle.org/news/">News</a></li>
<li id="menu-item-43826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43826"><a href="https://www.thetriangle.org/opinion/">Opinion</a></li>
<li id="menu-item-43827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43827"><a href="https://www.thetriangle.org/entertainment/">A&#038;E</a></li>
<li id="menu-item-43825" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43825"><a href="https://www.thetriangle.org/sports/">Sports</a></li>
<li id="menu-item-46975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46975"><a href="https://www.thetriangle.org/donate/">Donate</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.thetriangle.org/about/">About</a></li>
<li id="menu-item-43828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43828"><a href="https://www.thetriangle.org/staff/">Staff</a></li>
<li id="menu-item-43831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43831"><a href="https://www.thetriangle.org/advertising/">Advertising</a></li>
<li id="menu-item-43829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43829"><a href="https://www.thetriangle.org/classifieds/">Classifieds</a></li>
<li id="menu-item-43830" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43830"><a href="https://www.thetriangle.org/join/">Join</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44"><a href="https://www.thetriangle.org/contact/">Contact</a></li>
</ul></nav> </div>
<div class="footer-copyright">
&copy2020 The Triangle. All rights are reserved, except where otherwise noted.
</div>
<div class="footer-disclaimer">
The Triangle is an independent student organization and is not owned nor operated by Drexel University.
</div>
</footer>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.thetriangle.org\/sports\/drexel-mbb-week-5\/":51125};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.thetriangle.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"triangle"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"51125 https:\/\/www.thetriangle.org\/?p=51125","disqusShortname":"triangle","disqusTitle":"Men\u2019s Basketball loses three straight games","disqusUrl":"https:\/\/www.thetriangle.org\/sports\/drexel-mbb-week-5\/","postId":"51125"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var superpwa_sw = {"url":"\/OneSignalSDKWorker.js.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/super-progressive-web-apps/public/js/register-sw.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.thetriangle.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"0","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.4'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/jquery.viewport.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/search.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/themes/triangle-x-1.2.2/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=8.1.1'></script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thetriangle.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.1.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202006.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'21775326',post:'51125',tz:'-5',srv:'www.thetriangle.org'} ]);
	_stq.push([ 'clickTrackerInit', '21775326', '51125' ]);
</script>
</body>
</html>
